Přihlásit se

Joomla 4.2.5 aktualizace

Joomla 4.2.5 je nyní k dispozici ke stažení. Jedná se o bezpečnostní vydání. Joomla! 3.10 bude i nadále podporována bezpečnostními opravami až do 17. srpna 2023, což vám dává dostatek času na naplánování přechodu na Joomla! 4 a případnou aktualizaci rozšíření na verze kompatibilní s Joomla! 4.

Na jaké verzi Joomla + Virtuemart postavit e-shop dnes?

27. čvc 2022 18:11 #146695
Ahoj,
řeším dilema nemůžu najít kloudnou odpověď. Máte s tím někdo osobní skušenost?

Potřebuji udělat do konce prázdnin jednoduchý eshop, který musí mít OPC Rupostel, platbu kartou a zásilkovnu. To je podmínka. Mám zkušenosti s Virtuemartem ale ve verzi 3, čtverku jsem jen vyzkoušel ale tam nefunguje to OPC od Rupostelu a Zásilkovna. Taky jsem testoval Joomlu 4, což by bylo dobré nasadit už dnes, když trojková verze pomalu končí.

Uvažoval jsem i o Phoca Cart, ale nemám s ní žádné skušenosti, zda umí to co potřebuji.

Prosím, jakou kombinaci verzí Joomly a Virtuemartu zvolit?
Moc díky Leoš

.

27. čvc 2022 20:13 - 27. čvc 2022 20:18 #146696
Poděkovali: Leoš

27. čvc 2022 22:40 #146701
Odpověď od Rudolf
Joomla Expert
Zdravím
nevěřte všemu co František říká, on je obchodník a ne programátor :)
Jinak by už dávno opravil tu chybu tokenu zde na joomlaportale a další chyby...

Já velmi kvituji snahu protlačit původní českou aplikaci a fandím ji (Phoca Cart - také jsme pro ni naprogramovali 4 rozšíření a další dvě jsou před dokončením), ale musí u toho člověk přemýšlet (tzn. zatřepat nejprve hlavou aby začalo fungovat to co je v tom kulatém metr nad místem kde se setkávají nohy) a ne poslouchat vše co tady každý napíše. Phoca Cart má pořád své omezení a není vhodná na všechny typy eshopů.

Ale zpět k dotazu:
Jednoduchým pohledem na stránky Rupostelu je vidět že OPC je s VM4 kompatibilní, ale aktuálně se doporučuje ve verzi pro J3 (viz dále info o routeru)
Navíc získáte v pluginu OPC Zásilkovna i naše pluginy, které jsme naprogramovali společně s Rupostelem - Česká Pošta a Česká Pošta - Balík na poštu v ceně OPC. A co se týká platební brány - tam již od vzniku Gopay (2010) existuje rozšížení pro VirtueMart od Easy/Minion, v roce 2017 se přidalo Platiti.

Prověřená verze VirtueMartu je J3/VM4/OPC 2.0.427

Úpravy na verzi VM4 pro J4 stále probíhají, poslední 2 měsíce se intenzivně v DEV týmu řeší kompatibilita s novým J4 routerem == já bych tuto verzi nasazoval až příští rok.
(I když už příští měsíc začneme dělat dva obrovské eshopy na VM4 a máme na to celý rok, takže současně upgradujeme mnoho rozšíření pro J4 a použijeme poslední vývojářskou verzi VM4.0.7).

MiniJoomla! - www.minijoomla.org - eshop s rozšířením Joomla/VM
Email Manager - aplikace na správu šablon emailů pro VirtueMart
Easy Feeder - aplikace na generování XML/CSV feedů a napojení na ERP pro VM
PragueClassicconcert - portál pro prodej vstupenek na systému Joomla
Poděkovali: Leoš

28. čvc 2022 09:35 #146706
Odpověď od Leoš
Začátečník
Zdravím pánové a moc díky za info.
jestli jsem to správně pochopil, tak bych měl vycházet z Joomly v.3 a Virtuemart  v.4 nebo jít do Joomly v.4 a Phoca Cart.

jelikož jsem dlouhá léta zvyklý na Virtuemart, vychází mi z toho zatím Klasická kombinace J3 + VM3 (možná VM4) + potřebné pluginy. Jelikož se jedná o jednoduchý e-shop, tak případný upgrade nebude tak bolestivý.

Poslední dotaz: je velký rozdíl mezi VM3 a VM4? Je VM4 dobré nasadit na produkci?

Pokud bude dnes pokec večer, rád to proberu i tam.

Moc děkuji za vaše názory.
Leoš

.

28. čvc 2022 10:07 #146707
Odpověď od Linelabcz
Admin
Nasazovat Joomla 3 na nový projekt je chyba a nesmysl. Končí podpora Joomla 3. Joomla 4 je zcela jiný svět. K Virtuemart se vyjadřovat nebudu, stačí si přečíst forum na virtuemart.net. Rozhodně to není na produkci j4 a vm4, jak píše Ruda, možná za rok. Poslední eshop na Virtuemart jsme právě úspěšně dokončili a další na VM už prostě ne. :-) 

28. čvc 2022 12:06 #146709
Odpověď od xunil
Pokročilý uživatel
Joomla 3 dnes už fakt ne, pokud k tomu není extra důvod. Raději bych v takovém případě hledal řešení aby ten extra důvod neexistoval. Ruda má trochu specifické požadavky a hlavně moc moc hodin v J3. J4 není ideální jak by mohla být, to ale neznamená že je na produkci nepoužitelná. Možná může něco vadit ale obecně J3 končí ať už je to dobře nebo špatně.

Powered by Fórum