Přihlásit se

Joomla 4.2.5 aktualizace

Joomla 4.2.5 je nyní k dispozici ke stažení. Jedná se o bezpečnostní vydání. Joomla! 3.10 bude i nadále podporována bezpečnostními opravami až do 17. srpna 2023, což vám dává dostatek času na naplánování přechodu na Joomla! 4 a případnou aktualizaci rozšíření na verze kompatibilní s Joomla! 4.

Virtuemart

22. lis 2022 20:00 - 23. lis 2022 17:58 #147340
Odpověď od H13
Admin
Hugocz

Někteří lidé se ti zde snaží naznačit, že pro tvoji potřebu je vhodné prvně vyzkoušet Phoca Cart a v případě, že ti nebude vyhovovat, podívat se na jiné rozšíření včetně VirtueMartu.

Kombinace Joomla 4 a VirtueMart není pro tebe momentálně vhodná. Tato kombinace je momentálně vhodná pro pokročilé a dlouholeté uživatele VM, kteří vědí, co dělat v případě chyb, které reportuješ.

Z tvých komentářů vyplývá, že by ti měl po stránce vlastnostní stačit Phoca Cart. Navíc v Phoca Cartu dostaneš:

- moderní Joomlu 4 (Phoca Cart je vyvíjen už rok přímo pro Joomlu 4)
- moderní zobrazení - buď moderní Bootstrap 5 (nejnovější Bootstrap) nebo moderní UIkit
- žádné/případně minimum chyb

Pokud hledáš dokumentaci, zde:
- www.phoca.cz/documentation/category/116-phoca-cart-component
- www.phoca.cz/download/category/100-phoca-cart-component - nebo zde 222 stránková dokumentace (to, že je to v angličtině, neberu v době Google translatoru nebo Deepl jako nějakou překážku, navíc Phoca Cart je v ČR populární díky tomu, že je vyvýjen v Česku a uživatelé dostávají na česky kladené otázky okamžité odpovědi, okamžitou podporu).

Pokud potřebuješ katalog, Phoca Cart je na toto stavěný, navíc obsahuje propracované filtrovaní - pro katalog potřebné, příklad katalogu:
www.phoca.cz/jtd/

A řekněmě si konečně pravdu ohledně VirtueMartu. Problém VirtueMartu není v tom, že by to byl špatný program, problém je v tom, že se pro Joomlu 4 tváří jako stabilní program, což není. Pak dochází ke zmatkům a zklamáním. A na to doplácí také Joomla samotná. Pokud si nováček nainstaluje Joomlu 4 a VirtueMart, nabude ihned dojmu, že takové řešení je .... A opouští jak VM tak i Joomlu.

Proto prosím všechny diskutující, aby nováčkům nelhali a nevyvolávali v nich falešné naděje.

Pokud někomu doporučíme:

- VM 4 a J 4, uveďmě, že to není vhodné pro nováčky
- VM 3 a J 3, uveďmě, co uživatele čeká při migraci a také to, že J4 už je rok stabilní a brzy příjde J5

Pokud to tak nebudeme dělat, zbytečně dochází ke zklamáním a vyrábíme tak špatné jméno Joomle.

DŮRAZNĚ DOPORUČUJI NEDOPORUČUVAT NOVÁČKŮM INSTALOVAT JOOMLU 3 - Joomla 4 je už přes jeden rok stabilní a není žádný důvod doporučovat J3, J2.5 nebo J1.5. I když tyto instance pořád běží, běží hlavně díky tomu, že jsou provozováný:

a) buď odborníkem
b) nebo s velmi vysokým rizikem z hlediska bezpečnosti.

Pro použití pro nový projekt jsou zcela nevhodné.

Phoca Cart - www.phoca.cz/phocacart - e-shop, e-commerce
Phoca Gallery - www.phoca.cz/phocagallery - obrázková galerie
Phoca Download - www.phoca.cz/phocadownload - stahování souborů
Phoca Guestbook - www.phoca.cz/phocaguestbook - guestbook

23. lis 2022 10:49 - 23. lis 2022 10:57 #147343
Odpověď od Hugocz
Začátečník
V podstatě jsem se k tomuto propracoval a také jsem to už napsal. Možná jsem jen nezdůraznil, že jedinou chybou Virtuemartu je to, že dostatečně neinformují o tom, že pro J4 ještě není Virtuemart ve stabilní verzi. To jsem se dočetl až v této diskuzi. A nikde jinde to není. Na rozdíl třeba od vývojářů  J2Store, kteří na svém webu upozorňují, že přechod na J4 ještě nemají dokončen.

23. lis 2022 18:01 #147346
Odpověď od H13
Admin
Ano, J2Store je v podstatě placené rozšíření a ti si nemohou kvůli platícím zákazníkům dovolit vydat nedodělanou verzi, proto ohlásili, že stable bude asi příští rok. Což je velmi zodpovědné chování.

Phoca Cart - www.phoca.cz/phocacart - e-shop, e-commerce
Phoca Gallery - www.phoca.cz/phocagallery - obrázková galerie
Phoca Download - www.phoca.cz/phocadownload - stahování souborů
Phoca Guestbook - www.phoca.cz/phocaguestbook - guestbook

23. lis 2022 19:31 #147347
Odpověď od Linelabcz
Admin
Takže abychom to uzavřeli, vydání Virtuemart 4 s označením stable někdy v dubnu 2022 byla velká chyba. Je konec listopadu a stále je to spíše Beta verze.
Kdo ví, kolik uživatelů si "stable" nainstalovalo a pak se jen nestačili divit, jako někteří zde na fóru. V případě hlášení chyb se spíš obracejte přímo sem forum.virtuemart.net/index.php?board=127.0

23. lis 2022 22:59 #147348
Odpověď od Hugocz
Začátečník
V podstatě souhlasím, ale mám "pocit" že Virtuemart s označením 4 možná na J3 chodí. Chybou bych spíš označil použití Virtuemartu na Joomla4. Tedy chybějící info o problémech v případě nasazení na J4.

23. lis 2022 23:13 #147349
Odpověď od Rudolf
Joomla Expert

Takže abychom to uzavřeli, vydání Virtuemart 4 s označením stable někdy v dubnu 2022 byla velká chyba. Je konec listopadu a stále je to spíše Beta verze.


No já nevím co na to říct :)
Tak jak je to napsané, to u lidí co nejsou obeznámeni vyvolává pocit, že to je snad pravda a nezbývá používat jenom Phoca cart? :D

VM4 funguje bez zásadních problémů skvěle na J3.
Aktuálně třeba vím z chatu o přeprogramovaném stromu kategorií, který je extrémně rychlý a zvládne 300 000 kategorií.

Na J4 se stále ladí. Není to nějaký program na výpis článků.
Když si udělám srovnání, že Honza začal programovat více než před dvěma lety a dnes má stabilní verzi s omezeními, které vycházejí z podstaty základní koncepce a  srovnám to s tím, že VM se začal pořádně předělávat před rokem a je podstatně složitější, tak mi takové názory připadají spíše jako přání otce myšlenky.
Aby to bylo seriózní, je třeba dát tomu stejný čas.

A nebo ne, dyť si to tady pište, ti co nevědí se toho chytnou a uvěří, ti co vědí, si prostě počkají.

Problém s označováním verzí (Stable, RC,...) je známý již od verze 2.0. Prostě si to Max označuje jak chce. A zrovna tohle František ví a stejně to použije :D
Co na to říct?

Taky kdo ví, tak Max po mohutné kritice změnil označení na RC.

 

MiniJoomla! - www.minijoomla.org - eshop s rozšířením Joomla/VM
Email Manager - aplikace na správu šablon emailů pro VirtueMart
Easy Feeder - aplikace na generování XML/CSV feedů a napojení na ERP pro VM
PragueClassicconcert - portál pro prodej vstupenek na systému Joomla

Powered by Fórum