nejde se přihlásit do adminu

Odpověď od MaK.
26. úno 2019 23:16 #139249
Mně tohle u některých webů dělalo přepnutí na PHP 7.2. Ponížil jsem na 7.1 a už to zase jelo. Může to být však cokoliv jiného.

MaK.

--- -- -

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Martin Koumal
07. bře 2019 11:43 #139344
Děkuji moc za snahu pomoci a trpělivost - mám nyní přístup do logu a výpis přikládám...
Přílohy:

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Martin Koumal
07. bře 2019 11:44 #139345
Aktuální verze php je 5.6...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Martin Koumal
07. bře 2019 12:20 #139347
Dívám se, že log nejde přečíst... posílám tedy takto:

[Thu Mar 07 02:19:09.245242 2019] [ssl:warn] [pid 2368360:tid 140556542011200] AH01909: www.kzza.sk:443:0 server certificate does NOT include an ID which matches the server name
[Thu Mar 07 07:41:28.262714 2019] [lsapi:notice] [pid 2085177:tid 140555208038144] [client 95.82.129.212:56048] [host kzza.sk] Backend log: PHP Warning: escapeshellcmd() has been disabled for security reasons in /home/krestansk/domains/kzza.sk/public_html/libraries/vendor/phpmailer/phpmailer/class.phpmailer.php on line 1444\n
[Thu Mar 07 07:41:28.482858 2019] [lsapi:notice] [pid 2085177:tid 140555208038144] [client 95.82.129.212:56048] [host kzza.sk] Backend log: PHP Warning: escapeshellcmd() has been disabled for security reasons in /home/krestansk/domains/kzza.sk/public_html/libraries/vendor/phpmailer/phpmailer/class.phpmailer.php on line 1444\n
[Thu Mar 07 07:41:30.686199 2019] [lsapi:error] [pid 2084876:tid 140555312936704] [client 95.82.129.212:56053] [host kzza.sk] Backend fatal error: PHP Fatal error: Class 'JToolbarHelper' not found in /home/krestansk/domains/kzza.sk/public_html/administrator/components/com_cpanel/views/cpanel/view.html.php on line 36\n, referer: kzza.sk/administrator/
[Thu Mar 07 09:20:08.939086 2019] [ssl:warn] [pid 2368360:tid 140556542011200] AH01909: www.kzza.sk:443:0 server certificate does NOT include an ID which matches the server name
[Thu Mar 07 09:46:09.548449 2019] [ssl:warn] [pid 2368360:tid 140556542011200] AH01909: www.kzza.sk:443:0 server certificate does NOT include an ID which matches the server name
[Thu Mar 07 12:00:56.715268 2019] [:error] [pid 2261751:tid 140555281467136] [client 52.203.142.240] ModSecurity: Access denied with code 403 (phase 2). Matched phrase ".ini/" at TX:extension. [line "27"] [id "210730"] [rev "3"] [msg "COMODO WAF: URL file extension is restricted by policy||kzza.sk|F|2"] [data ".ini"] [severity "CRITICAL"] [tag "CWAF"] [tag "HTTP"] [hostname "kzza.sk"] [uri "/language/en-GB/en-GB.ini"] [unique_id "XID56Dmg8risfYDFc-PcewAAAQw"][file "/usr/local/cwaf/rules/11_HTTP_HTTP.conf"] [line "27"] [id "210730"] [rev "3"] [msg "COMODO WAF: URL file extension is restricted by policy||kzza.sk|F|2"] [data ".ini"] [severity "CRITICAL"] [tag "CWAF"] [tag "HTTP"] [hostname "kzza.sk"] [uri "/language/en-GB/en-GB.ini"] [unique_id "XID56Dmg8risfYDFc-PcewAAAQw"]

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Martin Koumal
07. bře 2019 12:21 #139348
mimochodem, pokud by se někomu chtělo zjistit problém a opravit ho, budu rád - samozřejmě za peníze :-)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
07. bře 2019 12:47 #139349
Zřejmě se bude jednat o tuto chybu:

PHP Fatal error: Class 'JToolbarHelper' not found in /home/krestansk/domains/kzza.sk/public_html/administrator/components/com_cpanel/views/cpanel/view.html.php on line 36

Mrkněte sem .

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Pavel [byPV]
07. bře 2019 12:52 #139350
No tak to skutečně vypadá na nepovedenou aktualizaci Joomla!, kdy se část systému aktualizovala a část ne. Asi netušíte jaká verze tam byla původně a jakou tam máte nyní (nebo spíše jste chtěli mít), že?

Na netu je několik případů se stejným problémem při aktualizaci z 3.8.x na 3.9.0, ale nějak nevidím, že někdo napsal jak k tomu došlo a oprava je tedy asi leda ručně. Zkusím poradit poslepu podle toho co obvykle píší lidé...

Podívejte se, zda-li máte v systému soubor /administrator/includes/toolbar.php .

Pokud ano, tak v souboru /administrator/index.php najděte řádek

require_once JPATH_BASE . '/includes/subtoolbar.php';

a hned za něj vložte následující kód

if(!class_exists('JToolbarHelper')) {
  require_once JPATH_ADMINISTRATOR . '/includes/toolbar.php';
}

Pokud ne (soubor /administrator/includes/toolbar.php tam nemáte), tak na stejné místo vložte toto:

if(!class_exists('JToolbarHelper')) {
  JLoader::registerAlias('JToolbarHelper', '\\Joomla\\CMS\\Toolbar\\ToolbarHelper', '5.0');
}

Pokud se po úpravě podaří dostat do administrace, tak ihned přejděte do Komponenty -> aktualizace Joomla! a klikněte na Zkontrolovat aktualizace a pak ji nechte znovu aktualizovat tlačítkem níže (počkejte až to komplet doběhne!!!!). Pokud hlásí, že je aktuální, tak dejte přeinstalovat soubory jádra (je tam na to také tlačítko).

Pokud je cokoli jinak (chybí soubory či řádky co jsem psal, tak napište kde co chybí)...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Martin Koumal
07. bře 2019 14:33 #139359
ten řádek jsem v index.php nenašel... jen

if (!defined('_JDEFINES'))
{
define('JPATH_BASE', __DIR__);
require_once JPATH_BASE . '/includes/defines.php';
}

require_once JPATH_BASE . '/includes/framework.php';

a administrator/includes/toolbar.php v souborech není.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
07. bře 2019 16:15 #139367
Já bych to nehrotil.

Jestli máte přístup na FTP. Nahrát instalační balíček Joomly + Kickstart.php, rozbalit - neinstalovat, smazat složku v FTP installation, přihlásit se, opravit v administraci databázi. Hotovo.

Ideálně před těmito kroky zálohovat alespoň nefunkční web.

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Pavel [byPV]
07. bře 2019 18:46 #139370

Martin Koumal napsal: ten řádek jsem v index.php nenašel... jen

if (!defined('_JDEFINES'))
{
define('JPATH_BASE', __DIR__);
require_once JPATH_BASE . '/includes/defines.php';
}

require_once JPATH_BASE . '/includes/framework.php';

a administrator/includes/toolbar.php v souborech není.


Jak jsem se ptal na ty verze, tak to tedy předpokládám nevíte, že?

Pokud máte v tom /administrator/index.php jen toto (příště to vložte do CODE), tak se díváte jinam, protože to je nesmysl. Něco musí být před tím i za tím. Pokud tam ten toolbar.php není, tak to musí být podle mého aktualizované prakticky dokonce a chyba bude buď v něčem jiném a nebo by mohlo zabrat druhé řešení jež jsem psal. Také je možné, že za to může jiné zastaralé rozšíření co tam máte (nebo šablona), ale ta aktuální chyba s tím asi nesouvisí. Jen tam možná budou další.

Souhlasím s Bongem, že tady to asi nemá cenu hrotit. Pokud chcete, ozvěte se mi na mail, ale tady by to mohlo být na dlouho, protože je lepší to vidět. Nemyslím si, že je hned nutné přeinstalovat celou Joomlu a zejména když prozatím nikdo neví (ani tazatel) v jakém je to stavu. Nikdy jsem to takto radikálně řešit naštěstí nemusel. Ani si nejsem jistý, jestli by to tazatel dle návodu od Bonga zvládl, pokud s Joomla nemá moc zkušeností.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Martin Koumal
11. bře 2019 09:15 #139385
Jak jsem se ptal na ty verze, tak to tedy předpokládám nevíte, že?

Pokud máte v tom /administrator/index.php jen toto (příště to vložte do CODE), tak se díváte jinam, protože to je nesmysl. Něco musí být před tím i za tím. Pokud tam ten toolbar.php není, tak to musí být podle mého aktualizované prakticky dokonce a chyba bude buď v něčem jiném a nebo by mohlo zabrat druhé řešení jež jsem psal. Také je možné, že za to může jiné zastaralé rozšíření co tam máte (nebo šablona), ale ta aktuální chyba s tím asi nesouvisí. Jen tam možná budou další.

Souhlasím s Bongem, že tady to asi nemá cenu hrotit. Pokud chcete, ozvěte se mi na mail, ale tady by to mohlo být na dlouho, protože je lepší to vidět. Nemyslím si, že je hned nutné přeinstalovat celou Joomlu a zejména když prozatím nikdo neví (ani tazatel) v jakém je to stavu. Nikdy jsem to takto radikálně řešit naštěstí nemusel. Ani si nejsem jistý, jestli by to tazatel dle návodu od Bonga zvládl, pokud s Joomla nemá moc zkušeností.[/quote]

Díky moc, píši email...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
11. bře 2019 09:46 - 11. bře 2019 09:47 #139386
Verze Joomly na tom webu je 3.9.2, takže opravdu stačí přes FTP přepsat instalaci třeba balíčkem Joomla! 3.9.x to 3.9.2 Patch Package a následně po přihlášení provést opravy a aktualizaci.

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Martin Koumal
11. bře 2019 11:17 #139388
Vše vyřešeno - díky skvělému zásahu Pavla Vakeše - jeho doporučení pro úpravu, které nakonec pomohlo je výše v diskuzi.
Moc děkuji a uzavírám téma.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.