problémy s IE

vrtaak
31. led 2019 13:30 #138749
Mám spíš obecný dotaz ohledně kompatibility nových webů se staršími prohlížeči, konkrétně IE 10.
Na webu postaveném v pagebuilderu Gridbox se objevil problém se zobrazováním náhledů u slideshow. Na všech prohlížečích to funguje bez problémů, v IE 10 jsou náhledy smrsklé do úzkého sloupce. Na dotaz na podpoře Balbooa Gridbox jsem dostal odpověď, že IE prohlížeče jsou outdated a že i Microsoft sám doporučuje Edge.
Tomu rozumím, ale nevím jestli je v pořádku tenhle přístup, že když se objeví problém na starém prohlížeči, tak ho odpálkuju s tím, že je outdated... Jak to vnímate vy?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od H13
31. led 2019 14:24 - 31. led 2019 14:33 #138750
Ber to z druhé strany. Bylo by v pořádku kvůli jednomu nestandardnímu zastaralému programu omezit ostatní uživatele standardních prohlížečů? A to omezení má mnoho podob. Např. kód by kvůli dělání berliček naboutnal a zpomaloval ostatní uživatele - a zbytečně. Práce strávená děláním berliček se může věnovat vymýšlení nových a moderních vlastností. Např. kvůli tomu, aby jsi něco přizpůsobil zastaralému nestandardnímu prohlížeči příjdeš o měsíc práce, kterou by jsi mohl věnovat potřebnějším věcem.

Tak trochu podobným příkladem může být jQuery - jedna z nejskvělejších knihoven na světě zažívá momentálně období, kdy ji každý "nýmand" osočuje z toho, že je pomalá a robustní, ale už si ti nýmandi neuvědomují, že jQuery za ně řeší nekonečně mnoho konfliktních situací, o kterých nemají vůbec tušení. Ta robustnost je zapřičiněna také právě podporou starších nebo nestandardních prohlížečů.

Tedy rozumím tomu, že prostě někdo nechce zbytečně komplikovat kód a ztrácet čas kvůli nestandardním zastaralým prohlížečům. A v některých případech by byl ještě osočován z toho, že díky podpoře zastaralých a nestandardních prohlížečů je jeho kód robustní a pomalý.

A to, že IE není jenom zastaralý, ale také nestandardní prohlížeč, pro který něco dělat, je peklo, to rozhodně nepřispívá k tomu, aby pro něj někdo dělal speciální podporu.

S nadsázkou říkávám, že, kdo používá IE, tak nikdy neviděl správně zobrazenou stránku a proto by pro něj byl šok, kdyby se tomu nějaký vývojář věnoval a udělal stránku, která by se zobrazovala správně i na IE. Tedy je také potřeba ochránit uživatele IE, aby nedostali např. infarkt, když by stránku viděli správně zobrazenou.

Phoca Gallery - http://www.phoca.cz/phocagallery - obrázková galerie (Joomla!)
Phoca Guestbook - http://www.phoca.cz/phocaguestbook - kniha návštěv (Joomla!)
Phoca Download - http://www.phoca.cz/phocadownload - stahování souborů (Joomla!)
Phoca Cart - http://www.phoca.cz/phocacart - e-shop,...
Poděkovali: Bong, vrtaak

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od hrackar
31. led 2019 14:32 - 31. led 2019 14:34 #138751
Dobrý den,

vždyť jste si odpověděl sám. IE10 a méně jsou "deprecated" a nejsou podporovány samotným Microsoftem. Dokonce je oficiálně nepodporuje ani naše státní správa viz: www.datoveschranky.info/-/ukonceni-podpo...lorer-verze-8-9-a-10 která jinak s gustem zdechlinu jako IE používala/používá.

Samozřejmě, že u státní správy to je trochu složitější stejně jako u korporátů a jejich integrace vlastních řešení do IE apod. Nicméně s pohledu například firmy co jste popsal je logické, že to neřeší už jen pro to, že jejich PB například běžně podporuje a používá spoustu nativních knihoven, rozšíření apod které zkrátka již IE implementací nezvládá / nezná různé deklarace apod.

Nevidím na to nic špatného. Obzvlášť když na webu sám vývojář oficiálně v dokumentaci neuvádí podporu pro IE viz: www.balbooa.com/gridbox-documentation/key-features kde v části "Requirements:" není ani Internet Explorer uveden: "Browser Requirements: Firefox, Chrome, Safari, Microsoft Edge, Opera."

Takže pokud nějaká podpora prohlížeče typu IE10 je tak není asi oficiální. Tím pádem jste dostal odpověď jakou jste dostal.

A to neřeším to, že Explorer něco dělat je za trest. To mizivé procento uživatelů co ještě IE používá snad do budoucna vymizí ostatně jako IE 6 a jiné.
Poděkovali: Bong, vrtaak

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od vrtaak
31. led 2019 15:12 #138753
Díky pánové. Já si myslím totéž, vím že IE je peklo, akorát sem to chtěl slyšet ještě od někoho jinýho, že už se tím dneska nikdo nechce zaobírat, jestli mu něco chodí nebo nechodí na IE. Potřeboval sem odbornou a morální oporu na ráznou odpověď jedné nepříjemné dámě používající IE 10... ;-)
Bohužel tenhle zastaralej krám nepoužívá žádný mizivý procento. Na webech co spravuju a co jsem se teď díval, používá IE pořád nějakých 10 až 20 (!) procent návštěvníků, z toho 3 - 7% jsou starší verze než IE 11... což je dost děsivý...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
31. led 2019 20:32 - 31. led 2019 20:33 #138757
pozor, EDGE je ještě horší
PS datové schránky v něm také neběhají

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.